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Hi-Tronic Keil pVision IDE ASM compile tutorial.
A How-To Guide.

http://www hi-tronic.ca/
1. To run the IDE, Click Start->Programs—>Keil uVision2.

2. Click Project->New Project, and then choose a working directory where you
will save all your work. The default path is C:\HiTronic.

3. Name your project. The default name is HT.Uv2. Click on Save to save the file.

Create New Project 2 x

Save jr: IaHiTrnnic j - IfF Ex-
|2 HT vz

File name: — [HT .U+ Save I
Save az ype: IF'n:uieu:t Files [*.uvZ] j Cancel |

A
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4. Once you have clicked on Save, a pop-up window will ask you what chip you
would like to use. For example, if you would like to use the CC1010 from
Chipcon, you must select Chipcon=>CC1010. Ensure that the “Use extended
Linker” option is not checked off, and click OK to continue.

Select Device for Target 'Target 1° i B

CFU |

Wendor  Chipoon

Devicer  CCI010 ™ Use Extended Linker [L¥51] instead of BLS1
Family: ~ MCS-51 ™| Use Extended Assemblen (351 instead of £57
Data base Description:
@ Analog Devices ﬂ 8051 Enhanced Microcontroller with d
@ AnchorChips 300-1000 MHz RF Transceiver
@ Atmal [Data Rates up bo 7E.8 kbit/s]
: . 2 7-36%alt Power Supply, DES Encrption,
e G Almel Wieless & uC 2 General /0 Pins, 4 Timers, 2 PMs,
=& Chipcon 2 UARTs, RTC, Watchdog Timer, SPI,
] 1010 3-Channel 10-bit &/0 Coreerter,

s T 32K Bytes Flash ROM, 2K+125 Bytes SRAM,
g Erbl;rr:;ifi:it:ss;lstems Full Systern Debugging with Keil Byisionz

@ CytraTech

e Cygnal Integrated Product
-5 Cypress Semiconductor
@ Daewon

@ Dallag Semiconductar

4 | » -
Ok I Cancel |

5. A new pop-up window will appear. It will ask whether you would like to copy
the standard 8051 startup code to the project folder. Unless you are an advanced
user, you should click No. If you click Yes, you will be faced with code and
options too advanced for beginners.

i

@ Copy Standard 8051 Startup Code ko Project Folder and #dd File ko Project: 7
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6. You have now created a project, but there is no source code. The program
should look like this:

{ii rcc - pvision2 =10l =|
|| Eile Edit Wiew Project Debug Flash Peripherals Tools SYCS Window Help

SHE YBR[ EE %% % =]
|| & Q|BE| o e e

# 4K |Target 1 =l

=l

------ |’_‘| Source Group 1

= @_J AE... |
g -

[A[ Ao ¥ Build £ Command A Findin Files f ||L|_|_’|_I
| | | om| | R

7. To create new source code, go to File>New.

8. Save your work. Go to File>Save As and then name your file. It should have a
.asm extension, like HiTronic.asm. You must save your file in the working
directory where you have saved your project.

9. You can now enter code into the text editor. To save time, copy the code found
in the appendix at end of this document and paste it into the text editor. When
you have done so, you will notice that the instructions are in blue, while the
comments are in green. Don’t worry if you don’t understand the code. What’s
important is that you are learning how to use the tools.
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10. Now you have source code, but it has not been added to the project. To add the
source code to the project, right-click on Source Group 1 and select Add files to

Group ‘Source Group 1°.

B HT - p¥ision2 - [C:\HiTronic\HiTronic.asm] 18|
JJE File Edit Yew Project Debug Flash Peripherals Tools SWCS Window Help _|- _|El |
D@ LR D Es 8% %% A =] ¢4
@& mEloerm
|| de s | % K Torger =
==l (DATE Definiticn aresa
WDT DATA 0DXED2
RS E”Je“ P1DIR DATA DXAS
Select Device for Targek Target 1
Options For Group 'Source Group 1
Open) File
Rebuild target )
Build target 7 “g ; Dizable the watchdog
Translate File 1] . Set Pl asz output
e Sfop i . send DXF0 to PORT 1
Add Files to Group 'Source Group 1' ¢ Call the loop delay
Targets, Groups, Files, ..
Remove Group "Source Group 1' and it's Files : repsat flash the port 1
’Tlgclude e Elme dalay 1= around ES*Ro*E7*xZ2%lu=
DL1: MOV E7.#200
DL2: DJHZ R7.DL2
DJHZ R6,DL1
DJHZ R%5.DLO
RET
- END
_;‘—1|||4|4|P|<| 3|
[ IFemee cap [ [t

Add Files ko cnrrant Pradeck Granin

11. A pop-up window will appear. Select the file you created. In this example, the
file is HiTronic.asm. Click on Add to add the file to the group.
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2]

Look ir: I {5 HiTranic

-] « & ex E-

HiTronic, asm

File name: | &dd
Files of type:  [RE e te=R 1Y | Cloze |

12. Now right-click on Target 1, and select Options for Target ‘Target 1’

HI_!E_HT - p¥ision2 - [C:\HiTronic,HiTronic.asm]

==l
Iaﬁile Edit Wiew Project Debug Flash Peripherals Tools SWCS window Help =181
BEE@ | ER |20 == 0% %% G =] ¢4
@& a mEloerm
) B W AR Target 1 =l ‘
== ;DATA Definition area
S W I WDT DATA DED2
Ea Select Device for Target 'Target 1
Options for Target 'Target 1'
@pen File
Rebuild target
|:%] Build target F7
. #£0X10 ; Disable the watchdog
Translate File ‘ FOEFT
Stopbgild IR, #0X00 ; S=t P1 as output
&dd Eiles to Group. .. CEDEFD ; ==nd 0XFO0 to PORT 1
F... [ Tetaehs, EeEs, FlEsu I ; Call the loop delay _}[
— Remoye Iem
2[Byuild
i aSSeml”TIDCIUdE Dependencies :
linking...
Program Size: data=8.0 xdata=0 code=98
creating hex file from "HI"...
"HT" - 0 Error(s), 0 Warningi(s).
AL« [
SRE Priviart nnkinns [ =T I [t

Page 6 of 17
© Hi-Tronic Inc. 2005. This document may not be reproduced with any
alterations without the prior written consent from Hi-Tronic Inc.



www.Hi-Tronic.ca © Hi-Tronic Inc 2005

13. A new window will open. Check Create HEX File to enable the program to
create hex files. Click OK to finish.

Options for Target ‘Target 1° 2=

Device | Target Output | Listing| C51 | 451 | BLS51 Locate | BL51 Misc | Debug | Utiiies |

| Select Folder for Objects. . I Mame of Executable: IFCC

{* Create Executable; Moo

¥ Debug Infarmation ¥ Browse Information [ Mernge32K Hexfile

File HE Format: |HE-20 j

" Create Librany: Arcc.LIB [ Create Batch File
—After Make
¥ Eeep'when Complete [ Start Debugaing
™ Run User Program #1; I Browse... |
™ Run User Pragram #2: I Browse. .. |
ok, | Cancel | Defaults |

14. You can now compile the code. Go to Project->Rebuild All Target Files. Your
code will be rebuilt and compiled into a HEX file.
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HI_!E_HT - p¥ision2 - [C:\HiTronic,HiTronic.asm] 18]

Iaﬁile Edit ¥iew |Project Debwg Flash Petipherals Tocls sWCS window Help 18l

S =] | Mew Praject... h’ﬁ

Irnport piisionl Project, ..

LE | @ | @ ||Ei Open Project

” & | Close Project
File Extensions, Books and Environment
E1-5-9 Target 1 Targets, Groups, Files...

Ea Source ¢ Select Device For Target Target 1'
HiTr Remayve Graup 'Source Group 1 and it's Files
Cptions for Target ‘Target 1'

Clear Group and File Options

; Digable the watchdog

; S=t P1 as output

K Stop build : send 0DEF0 to PORT 1
34 Flash Dovinload © Call the loop delayw

[v 1 caHTroniciHT vz

2 @iPronounceltestircc,uvE
3 G:\Pronounceltest|EDGE. vz F dalay iz around RExRExR7*lelu=

= - h 4 @:iPronounceltestitest, uvz _Fl
e 5 kel TS INCICHIPCONIFD uv2

=|[Build targ: & GiPronounceladucsel L
L assembling 7 Giwirelessinrfoes _wikihh,Uvz

linking.. : 8 GihwirelessinrFoes_WilexZo-tx, L2
Program 3i: 9 G@:wirelessinrf9es _wihexZo-rx. L2

; hy
%I :m 10 Giwirelessinrf9e5 WK pwrDown, vz ILI-
Rehuild all karget files [ i c:a MLIM Ry

;. repeat flash the port 1

15. You are now able to download the .hex file to the hardware by using third-party
software like Hi-Tronic’s Microcontroller programmer. This software is
available for download from the Hi-Tronic website.

16. Go to http://www.hi-tronic.ca/index.php?site=software and click on the link for
the USB Programmer Software v2.1. Use this program to download the .hex file
to your hardware.
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Appendix: HiTronic.asm source code

;DATA Definition area
WDT DATA 0XD2
P1DIR DATA 0XAS5

; VECTOR AREA
ORG 00H
SJMP MAIN

;MAIN CODE AREA

ORG 040H

MAIN:
ORL WDT, #0X10
ANL WDT, #0XF7
MOV P1DIR, #0X00

HiTronic:
MOV P1, #O0XFO
ACALL DL
MOV P1l, #0XOF
ACALL DL
SJMP HiTronic

DL: MOV R5, #20
DLO: MOV R6, #120
DL1: MOV R7, #200
DL2: DJNZ R7, DL2

DJNZ R6, DL1
DJNZ R5, DLO
RET

END

Disable the watchdog

Set Pl as output

send 0XFO to PORT 1
Call the loop delay

repeat flash the port 1

time delay is around R5*R6*R7*2*1lus
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How to debug the ASM file.

1. If you want to debug, go to Debug—> Start/Stop Debug Session to enable the

l‘I-!E_HT - p¥ision2 - [C:\HiTronic\HiTronic.asm]

Eﬁile Edit Wiew Project |Debug Flash Peripherals Tools SW2S Window Help

Q@ -
W & @ mmE|
S il

=184 Target 1
Ea Source Group 1
oo [£] HiTranic.asm

B J§. 8

'E-ta Stop Debug Sessio

5

E—]

Go

1 step

LOAD e
* &Qﬂl '{_}‘1 Step Gver
| {ril Step Qut of current Funckion

¥ Fun o Cursar line
9 Stop Bunning

F5

F11

F10
Chrl+F11
Chrl4-F10
EsC

Breakpoints, ..
oM Insert/Remove Breakpoint
m EmableDisable Breakpaink
Disable All Breakpaoints
& Kill Al Breakpoinks
W Show [ext Statement

Di=zable the watchdog

Set Pl az output

5% EnablejDisable Trace Recording
{}2 Wiew Trace Records

=end 0XF0 to PORT 1
Call the loop delay

Memary Map...

Performance Analyzer, ..

Inlime Assembly, .

Function Editar {@pen Ini Fle)...

repeat flash the port 1

dalay iz around REE*RE*E7=2#%lus

linking...

% Build target 'Target 1'
assembling HiTronic.asm. ..

Program Size: data=8.0 xdata=0 code=98

Cne hew £ile Frem CHTH
mE K

)

ChowbdChmm Pinbi i S mime

ninina Im

=T
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2. Go to Peripherals and select the appropriate 10 port.

B HT - p¥ision2 - [C:\HiTronic\HiTronic.asm] =18
JJFE’| Fil= Edit View Project Debug Flash | Peripherals Tools SWCS Window Help =181
O
,I%B,,nﬁ|‘% E|ge Bt Reset CPU Eﬂtlm 'IM
3 |8 |[@ |mE | O g 50§ e

IjO-Porks Port 0

||& @ % | % KFage " sed > [v T
==l Timer 4 Port 2
Register | Value I;| Clock Cortral Port 3
oo Ul ;vzcron acm x
0:00 CIHP MAIN Fort 1 ;
0x00 i P‘I'Iﬁ 7 Bits 0
_ : mEEm
000 :MAIN CODE AREA Midlvlvlviviviy
0400 R D4H ns: [WF | vV
P WATN: oRL wypT, | F RV L, g
: = ANL UDT. —weer
Files @Rﬂgs |m500k8 | ‘ WOV PIDTR  #0¥AN c Set Pl a= nutrmt _}l
leoad "C:nHial fll Address: L0140 }: H| Name
C:0=0040: 43 D2 10 53 D2 F7 75 A5 00 75
C:0x004&: 90 FO 11 55 75 90 OF 11 55 80
C:0x0054: F4 7D 14 7E 78 7F ('S DF FE DE
C:0x005E: FA DD F6 22 00 00 00 00 00 0O
C:0x0068: 00 00 00 00 0D OO0 OO 0O 00 00
C:0x0072: 00 00 00 00 OO0 OO OO 0O 00 00
C:0x007C: 00 00 00 00 OO0 OO0 OO 0O 00 00
C:0x0086: 00 00 00 00 OO0 OO0 OO 0O 00 0O
> C:0x0090: 00 00 00 00 OO0 OO0 OO0 00 00 00
C:0x00%%: 00 00 00 00 00D OO OO 0O 00 00
ASM ASSTGN H O==00& 4« 00 NN _00 00 00 00 O 00 00 0n ;I
[4]»][<]] [ 4[> [#1Th memory #1 £ Mernory #2 M Wemony #5 A Wemory #4 F [ AT e [ Loeats £ wiatch #1 Ao

[ IFemee (T [T
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3. To debug the program go to Debug—> Step or Debug—> Step Over. The Step
command will debug the program one line at a time. The Step Over command
will debug a single line or an entire subroutine, depending on where the pointer is
pointing. If the pointer is pointing to a single instruction, only one instruction will
be executed. If the pointer is pointing to a subroutine, the entire subroutine will be

executed.

l‘I-!E_HT - p¥ision2 - [Disassembly]

@Eile Edit Wiew Project |Debug Flash Peripherals Tools SW2S Window Help

5

;i% = n ﬁ | ‘% ’@StartIStop Debug Session ChrHFS ﬁ h
@ | @B e -
™ Fi1
e # %] TP step over o LOBMBO D s aRrsEE >
{1 Step Qut of current Funckion Chrl+F11 AMALL DL
Register | Value ¥ Rum o Cursor line Chrl+-F10 1155 ACALL DL(C:0055) !
B Regs €3 stop Rumning Esc AIMP HiTronie ; repeat flash
o Breakpoints... 50F4 SIMP HITRONIC (C:0049)
renn WM Insert/Remove Breakpoint L: MOV RS, #20 time dalay is arou
Files 3 Regs I@ I Enable/Disable Breakpoint 7014 MoV RE, #0x14 o
Disable all Breakpoints
él Load "C :\\Hi*l i kil All Breakpoinks = :‘l Mame
o " g Show Negt Statement T
75 A5 00 75
22 Enable/Disable Trace Recording OF 11 55 &80
{}i igw Trace Recards C8 DF FE DE
goo oo o0 oo
Mernary Map. ., oo 00 00 oo
Performance Analvzer... gg gg gg gg
Inline Assembly...
Function Editar (Open Ini Filg). .. gg gg gg gg
C:0z009A4: 00 OO OO OO OO OO OO OO 0O 0o
C:0xz00&4: 00 OO OO OO OO OO OO OO OO OO
C:0xz00&E: 00 OO OO OO OO OO OO OO 0O OO0
? C:0xz00BS: 00 OO OO OO OO OO OO OO 0O 00
AWM ASZTAER Ij C:0z00C2: 00 OO OO OO OO OO OO OO0 00 0o ﬂ
I ERE | [A[A TR I temory #1 £ Mermory #2 } Mernory #5 H Mermory #4 f [T M Locals £ wateh &1 A L
Skem inkn [ [ o Ry
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4. Press F11 to continue to step through each line of the program. A small yellow
pointer will indicate which instruction will be executed.

HI_!E_HT - p¥ision2 - [C:\HiTronic,HiTronic.asm]

Iaﬁile Edit Wiew Project Debug Flash Peripherals Tools SWCS window Help

5k

D@ R =

2 8@ mE| %o

& 7 7 Ve ST ~| #h

o

E I ET R IR

=
. (@]

:VECTOR AREA
ORG 00H
SJHE MAIN

CMAIN CODE AREA
ORG 040H
MAIN: ORL WDT, #0¥10
ANL WDT. #OXF7

MOV P1DIRE. #0X00

HiTronic:MOV P11, #0HFD
ACALL DL
MOV P1. #0¥0F
ACALL DL
SJHF HiTronic
DL: MOV RG.#20
DLO: MOV Rb,#120

TTA . WA D7 #7900

K1

; Di=zable the watchdog

; 5=t P1 az output

; =end 0XF0 tao PORT 1
> Call the loop delay

o repeat flash the port 1

tine dalay iz around RExREexE7#2xlu=

Load "C:~Hix]

>
ASM ASSICN #
Malpil«l] >

L= |

x|

I

Address: ID;IJXD

=

Mame

l
A

(0z00:
:0z0B:
(0zl6:
(0z21:
(0z2C:
'DXSF'

(==l R i)

oo ] hd|

Memory #1 A Mernory #2 . Mernory #5 A Mernory #4

SN L lilgtch #1 A L

Locals

Ready

[ [RFCY
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5. You do not have to activate the disassembly window to step through the code.
However, can view the source code and OP-Code in the same place by going to
View—>Disassembly Window.

l‘I-!E_HT - p¥ision2 - [C:\HiTronic\HiTronic.asm]

Eﬁile Edit |Wiew Project Debug Flash Peripherals Tools SW2S  Window Help

_;i% D’u n ’7 Status Bar
,T File Toolbar
Qﬁ | & ||E ,7 Build Toolbar
) ,T Debug Toolbar

5

% b Ve Ga MR ~| &h

—_— ’@ Project Window
’E Qukput Window

([ Source Browser

(VECTOR AREA
ORG 00H
SJMEP MAIN

’@‘ isassembl ]

ﬁ Wyatch & Call Stack Windaw

Memory Windaws

W Code Coverage Window
Symbol Window

g Serial Window #1

&8 corjal Window #2

CMAIN CODE AREA

ORG 040H

HATH: ORI] WDT, #0OX10
ANL WDT. HOUE?
MOV P1DIR. #0X0OO

HiTronic: MOV P11, #0XFO0
ACALL DL
MOW P11, #0XOF
ACALL DL
SJHMF HiTronic

7

; Dizable the watchdog
: Set Pl as output

; =zend 0XFO to PORT 1
: Call the loop delav

: repeat flash the port

MOV RS, #20 time dalay is around RE=RE#]
L__b P Toohox DLO: MOV RE,#120
O Fl T - WO T #9nn
E ,T Periodic Window Update _>|‘
jILOEld " Workbook Mode }; é! e
v Include Dependenici i
’_n°9e Ependences 00 00 00 00 00 4E 00 00
BTS00 ) 00 00 00 00 00 00 00 0O
D:0x16: 00 00 OO0 00 OO0 00 00 0O OO 0O 0O
5 D:0x21: 00 00 OO 00 OO0 00 00 00 OO 00 0O
Ij D:0z2C: 00 00 OO0 00 OO0 00 00 00 OO 00 00
ASM ASSTGN |- D:0x37: 00 00 00 00 00 00 00 00 00 00 00 =
I ERE | [A[A TR I temory #1 £ Mermory #2 } Mernory #5 H Mermory #4 f [T M Locals £ wateh &1 A L
PicAzsrmbly Windnw [ Itz [ T R
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6. Now, press F11 to continue to step through each line of the program. A small
yellow pointer will indicate which instruction will be executed. The Op-code is in

red.
P HT - p¥isionZ - [Disassembly] 18|
JJ@ File Edit ‘Yiew Project Debug Flash Petipherals Tools SWCS  Window Help ==
DEHd s BR o =EEsmur@M@ 00000 4
®| & |a | |BE o e 0 m
& W K [Target Flsmeoned o [@REY 8EE 2
=l 14: |
Register | Vel |;| C:0x0046 75A500 MOW PIDIR(0xAS) ,#0=00
S Regs — 15: HiTronic:MOV P1,#0XF0 ; send OXFO to PORT 1
el w0 C:0x0049 7590F0 MOW P1i0x90),.#B(0=xF0)
- 000 16: ACALL DL : Call the loop delay
o i R4l C:0x004C 1155 ACALL DL(C:0055)
B fies 5P Regs |m|Books | T 17: MOW P1,#0X0F f
leoad "C:nHial i‘ ddress: 040 }; =] Name
C:0x0040: 43 D2 10 53 D2 F7 75 A5 00 75
C:0x004A: 90 FO 11 55 75 90 0OF 11 55 80
C:0x0054: F4 YD 14 7E 78 7F C8 DF FE DE
C:0x005E: FA DD Fe 22 00 OO0 00 00O OO 0O
C:0x0068: 00 00 OO 00 00 OO 00 00 OO0 oo
C:0x0072: 00 00 OO0 00 00 OO0 00 00 OO0 oo
C:0x007C: 00 00 OO0 00 00 o0 00 00 OO0 oo
C:0x0086: 00 00 OO 00 0O OO 0O OO OO0 0o
C:0x00%20: 00 00 OO0 00 00 OO0 00 00 OO0 oo
C:0x00%9x: 00 00 00 00 00 OO0 00 00 OO0 oo
C:0x00A4: 00 00 OO 00 0O OO 0O OO OO0 0o
C:0x00AE: 00 00 OO0 00 00 OO0 00 00 OO0 oo
? C:0x00BS: 00 00 OO 00O 0O OO 0O 00 OO0 oo
ASM ASEIGN |+ C:0x00C2: 00 00 OO0 00 00 OO0 00 00 OO0 oo |
[4]»][<]] [ AT F[FIh memory #1 £ Merory #2 K Wemony #5 b Wemmory #4 [ AT e [ Loeats £ wiatch #1 Ao

Reardy [ [ [ Inra [T

7. To view the code memory, data memory or external memory, go to
View—>Memory Window.
To view the CODE memory, go to the Address box and type C: and the line
at which you would like to start. For instance, to begin from 0x40, type
C:0X40.

To view the DATA memory, go to the Address box and type D: and the line
at which you would like to start. For instance, to begin from 0x40, type
D:0X40.

To view the EXTERNAL memory, go to the Address box and type X: and
the line at which you would like to start. For instance, to begin from 0x40,
type X:0X40.
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8. To debug the serial port, go to Peripherals—=> Serial. You will then see the
following pop-up window:

x
i fata /=3 2Bt Shift B eqister
SCOMO: {000 SADDHEI:IEI:-:EIEI

SBUFQ: |0=00  SADEND: I 0=00

[T sMz0 [ TeEE Ol RE&DO
[~ sWoDo [~ FE_O [T REM_D

— Baudrate

[T sWoD_ol RCLE [T TCLE

Transmit Baudrate; IEEIEIEIEIEIEI
Feceive Baudrate; |2EIEIEIEIEIEI

~IRG

1.0 [ RLD

9. To debug the timer, go to Peripherals=>Timer. You will then see the following
pop-up window:

Timer; Counter 0 x|

— Timer/Counter 0—————————————
taode

I Tirner j

TCOM: IIZI:-:IIIIZI THOD: IEI:-:IZIIII
THO: |EI:-:IIIEI TLO: ||:|:-:|:||:|

[¥ TOPin [~ TFO
Contral

Statuz: IStu:up

[T TRO [ GATE v IMTO#
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10. To watch the interrupt table, go to Peripherals—=>Interrupt. You will then see the
following pop-up window:

x
Int Sourze | ‘»-’eu:tu:url I'v1|:u:|e| Heql Enal F'ril -
P3.2/Int0 0003H 1] 1] 1] 1]

Tirner 0 Q00BH n 1] 1]
P2.24nt1 n01zH 1 1 1] 1]
Tirmer 1 Q01BH n 1] 1]
Sefial Rov.0 0023H n 1] 1]
Serial Hmit.0 0023H n 1] 1]
Tirmer 2 Q02eH 1 1] 1]
P1.1/T2E= 002BH n n 1] 1]
Fower Fail 003=H n 1] e
Serial Row. 1 003EH n 1] 1]
Serial Hmit. 1 Q03eH 1 1] 1]
P1.4/Int2 0043H n 1] 1] ;I
Selected Interupt
[ EA ’7|- ITEE [ IED [ ExD F'ri.:IEI

11. To exit the debug mode, go to Debug—> Stop Debug Session.
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